Skip to the content.

CVE-2022-25152 - ITarian - Any user with a valid session token can create and execute agent procedures and bypass mandatory approvals

CVE CVE-2022-25152
Case DIVD-2021-00037
Credits
Products ITarian:
  • ITarian platform (SAAS / on-premise)
Versions ITarian:
  • ITarian platform (SAAS / on-premise)
    • any version (< 6.35.37347.20040)
Page author Victor Pasman
CVSS Base score: 9.9
References
Last modified 08 Dec 2022 16:28

Description

The ITarian platform (SAAS / on-premise) offers the possibility to run code on agents via a function called procedures. It is possible to require a mandatory approval process. Due to a vulnerability in the approval process, present in any version prior to 6.35.37347.20040, a malicious actor (with a valid session token) can create a procedure, bypass approval, and execute the procedure.

This results in the ability for any user with a valid session token to perform arbitrary code execution and full system take-over on all agents.


JSON version